Vandal

Crasheo Bioshock 2

manumulti
Lugar: · 380 mensajes · Colección
PlayStation NetworkEnviar mensajeAgregar amigoVer relación
#1  Enviado: 09:39 19/11/2013

Buenas.

El tema es ese, el Bioshock 2 me crashea al poco de empezar a jugar, he buscado soluciones en internet pero no he encontrado nada que lo arregle. Si alguien diera con la solución se lo estaría eternamente agradecido.

Un saludo y gracias por adelantado.
Hollywood
Σ( ̄ω ̄;)       ¡Soy Satchii!
Lugar: Ghost Island · 13193 mensajes · Colección
PlayStation NetworkXbox LiveSteamBlogEnviar mensajeAgregar amigoVer relación
#2  Enviado: 09:49 19/11/2013

Lo mismo es por el Windows Live. Se supone que lo están quitando de los juegos y si al Bioshock 2 aun lo sigue utilizando lo mismo entra en conflicto al no esta operativo o vete a saber.

Yo cuando jugué utilicé un fix que haycon el que puede jugar al juego sin tener que esta utilizando Windows lIve. En el caso de que aBioshock 2 aun no lo intente seguir utilizando prueba a utilizarlo.
❤ ❤ ♪ ♪ ♫ ♫ Take my hand, take my whole life too. For I can't help falling in love with you... ♫ ♫ ♪ ♪
FuKuy
Proud PC gamer
Lugar: Barcelona · 17510 mensajes · Colección
SteamTwitterBlogEnviar mensajeAgregar amigoVer relación
#3  Enviado: 09:50 19/11/2013

Difícil, por no decir imposible, sugerir alguna solución sin tener más datos. La primera regla de oro es ayuda a que te ayuden. Guiño
Praise Lord Gaben
manumulti
Lugar: · 380 mensajes · Colección
PlayStation NetworkEnviar mensajeAgregar amigoVer relación
#4  Enviado: 10:09 19/11/2013

Pues a ver, el problema es que cuando crashea no me aparece ningún mensaje que me indique qué tipo de error es. Sé que no puede ser problema del ordenador porque me funcionan juegos superiores (Bioshock 2 no es que sea una bestia gráfica). Probé a desinstalar el GFWL y a reinstalarlo pero el problema persiste. También he reinstalado el juego y nada.
FuKuy
Proud PC gamer
Lugar: Barcelona · 17510 mensajes · Colección
SteamTwitterBlogEnviar mensajeAgregar amigoVer relación
#5  Enviado: 10:15 19/11/2013

En respuesta a manumulti (réplica 4).
Pues a ver, el problema es que cuando crashea no me aparece ningún mensaje que me indique qué tipo de error es. Sé que no puede ser problema del ordenador porque me funcionan juegos superiores (Bioshock 2 no es que sea una bestia gráfica). Probé a desinstalar el GFWL y a reinstalarlo pero el problema persiste. También he reinstalado el juego y nada.
A ver si me explico... cuando vas al médico no puedes decir: "doctor, me duele, ayúdeme" y ya está. El doctor necesita información: desde cuando te duele? dónde te duele? qué tipo de dolor es? te ha ocurrido antes? etc, etc.

Lo mismo con la informática en general: specs de tu equipo? has comprobado las temperaturas? has actualizado drivers? te ocurre con otros juegos? has cerrado todos los programas en segundo plano? etc, etc.

Sé que no puede ser problema del ordenador porque me funcionan juegos superiores


Ahí está tu error. El problema precisamente es ese. Que hay algo en tu PC (hardware o software) que el juego no soporta, de ahí el crasheo.

Probé a desinstalar el GFWL y a reinstalarlo pero el problema persiste


BioShock 2 ya NO usa GFWL. Tienes que asociar el juego a tu cuenta de STEAM y arrancarlo desde ahí.
Praise Lord Gaben
manumulti
Lugar: · 380 mensajes · Colección
PlayStation NetworkEnviar mensajeAgregar amigoVer relación
#6  Enviado: 19:45 19/11/2013  Editado: 19:47 19/11/2013 (1 vez)

En respuesta a FuKuy (réplica 5).
En respuesta a la réplica #4
A ver si me explico... cuando vas al médico no puedes decir: "doctor, me duele, ayúdeme" y ya está. El doctor necesita información: desde cuando te duele? dónde te duele? qué tipo de dolor es? te ha ocurrido antes? etc, etc.

Lo mismo con la informática en general: specs de tu equipo? has comprobado las temperaturas? has actualizado drivers? te ocurre con otros juegos? has cerrado todos los programas en segundo plano? etc, etc.

Sé que no puede ser problema del ordenador porque me funcionan juegos superiores


Ahí está tu error. El problema precisamente es ese. Que hay algo en tu PC (hardware o software) que el juego no soporta, de ahí el crasheo.

Probé a desinstalar el GFWL y a reinstalarlo pero el problema persiste


BioShock 2 ya NO usa GFWL. Tienes que asociar el juego a tu cuenta de STEAM y arrancarlo desde ahí.
Mi PC es un i5 de segunda generación, la gráfica es una nvidia geforce gt  540m, 4gb de ram y windows7 de 64bits. No he tenido problema con las temperaturas. Los drivers están actualizados (aunque hoy han salido unos nuevos).
Lo arranco desde steam. El juego está actualizado a la última versión, la 1.5 algo.

No, no me ocurre con otros juegos.
Naer
Games can't fail, only developers can
Lugar: Ciudad 17 · 19007 mensajes · Colección
TwitterBlogEnviar mensajeAgregar amigoVer relación
#7  Enviado: 20:12 19/11/2013

¿Has verificado la cache? ¿algun programa tipo fraps o D3DOverrider en segundo plano? ¿antivirus/firewall?
¿Alguien me podria explicar por qué internet esta lleno de paladines que salvaguardan la integridad y el honor de multinacionales a las que les importamos una putisima mierda?
FuKuy
Proud PC gamer
Lugar: Barcelona · 17510 mensajes · Colección
SteamTwitterBlogEnviar mensajeAgregar amigoVer relación
#8  Enviado: 20:28 19/11/2013

En respuesta a manumulti (réplica 6).
En respuesta a la réplica #5
Mi PC es un i5 de segunda generación, la gráfica es una nvidia geforce gt  540m, 4gb de ram y windows7 de 64bits. No he tenido problema con las temperaturas. Los drivers están actualizados (aunque hoy han salido unos nuevos).
Lo arranco desde steam. El juego está actualizado a la última versión, la 1.5 algo.

No, no me ocurre con otros juegos.
Ufff.. en un prtátil siempre viene mucha mierda preinstalada. Asegúrate de cerrar cualquier proceso innecesario antes de arrancar el juego.

Dicho lo cual, un consejo: SIEMPRE que tengas un problema en algún juego para PC, consulta PC Gaming Wiki. Fíjate que en la ficha de BioShock 2 comentan un posible crash al iniciar: pcgamingwiki.com/wiki/Bioshock_2

Crash on startup

Fix Change read/write permissions of save file

   1. Backup the Bioshock 2 folder from your My Documents folder.
   2. Delete the original Bioshock 2 folder.
   3. Launch BioShock 2 and begin a new game.
   4. Save your game and exit BioShock 2.
   5. In My Documents right-click on the new Bioshock 2 folder that was created and select Properties.
   6. Disable the Read-Only checkbox and click OK.
   7. Move any backed-up save files back into the new Bioshock 2 folder under \Bioshock 2\SaveGames\.
   8. Ensure that any file moved back into the new folder also has the Read-Only checkbox disabled.


De nada.
Praise Lord Gaben
manumulti
Lugar: · 380 mensajes · Colección
PlayStation NetworkEnviar mensajeAgregar amigoVer relación
#9  Enviado: 21:38 19/11/2013

En respuesta a FuKuy (réplica 8).
En respuesta a la réplica #6
Ufff.. en un prtátil siempre viene mucha mierda preinstalada. Asegúrate de cerrar cualquier proceso innecesario antes de arrancar el juego.

Dicho lo cual, un consejo: SIEMPRE que tengas un problema en algún juego para PC, consulta PC Gaming Wiki. Fíjate que en la ficha de BioShock 2 comentan un posible crash al iniciar: pcgamingwiki.com/wiki/Bioshock_2

Crash on startup

Fix Change read/write permissions of save file

   1. Backup the Bioshock 2 folder from your My Documents folder.
   2. Delete the original Bioshock 2 folder.
   3. Launch BioShock 2 and begin a new game.
   4. Save your game and exit BioShock 2.
   5. In My Documents right-click on the new Bioshock 2 folder that was created and select Properties.
   6. Disable the Read-Only checkbox and click OK.
   7. Move any backed-up save files back into the new Bioshock 2 folder under \Bioshock 2\SaveGames\.
   8. Ensure that any file moved back into the new folder also has the Read-Only checkbox disabled.


De nada.
Bueno, he seguido esos paso y parece que si funciona, aunque es pronto para cantar victoria. Cuando lo juegue a fondo veré si se ha solucionado de verdad.

La página me la apunto, es bastante útil.

Muchas gracias por la ayuda Fukuy. Por cierto gran trabajo en tus vídeos, me gustan bastante tus apariciones en Youtube.

Un saludo.
Lugar: · 1 mensajes · Colección
Enviar mensajeAgregar amigoVer relación
#10  Enviado: 14:01 16/03/2015

Buenas.

Leyendo este foro queria ver si podria solucionar mi problema con el crasheo de mi juego Bioshock 2 pero a mi no me ocurre lo mismo.

Explico: mi problema en el juego es que mientras estoy jugando tranquilamente de repente el juego se para y se cierra de repente sin mostrarme ningun tipo de error ni alerta, simplemente se cierra. Hace tiempo buscando encontre que era problema del direct 11 y que se solucionaba arrancandolo con direct 9 pero aun asi el crasheo sigue existiendo y se me sigue cerrando el juego, repito sin mostrar alerta ni error.

Tengo un i5, con una gtx 750, 16 Gb de ram y windows 7 de 64 bits por si te sirve de algo la especificacion de mi torre.

Espero que aunque este post lleve dos años sin movimiento puedan ayudarme alguien con mi problema ya que es una saga que me encanta pasarmelo unas cuantas veces.

Muchas gracias un saludo y espero una pronta respuesta^^.
Este tema está inactivo y no se puede replicar más.
Buscar en el foro: En foro: Tipo:
Foro de Vandal
>
Flecha subir